linux下安装npm报错解决办法 - TOMMYHU - 专注互联网开发及运营技术,提供相关资料及软件下载,奇趣网络时事评论!
Sep 24

linux下安装npm报错解决办法 不指定

tommyhu , 22:22 , Linux , Comments(0) , Trackbacks(0) , Reads(3367) , Via Original Large | Medium | Small
最近在linux下启动一个node的app.js进程,由于错误而挂掉,于是想使用forever开启守护,发现使用npm install forever -g无法安装,原来是npm没有安装,但是安装也是报错,怎么半呢?
以下是无法安装npm解决办法
1、键入node -v查看node版本
   例如:0.10.29

2、打开网页查看 http://nodejs.org/dist/npm-versions.txt  node和npm版本对照,如果没有对照的找上一个版本
   例如这里为:
   v0.10.26 1.4.3
   v0.11.0 1.2.15
那我去找npm 1.4.3

3、到http://nodejs.org/dist/npm/下载npm 1.4.3
   这里下载npm-1.4.3.zip

4、将这个包传到服务器解压 unzip npm-1.4.3.zip
   例如我的目录是/smartac/npm/

5、找到configure所在目录,我的是/smartac/npm/node_modules/npm
6、编译文件make && make install

7、编译ok后,键入npm查看是否安装成功
8、全局安装forever,命令npm install -g forever
9、将service守护forever start app.js

▲返回顶部

Add a comment

Nickname

emotemotemotemotemotemotemotemotemotemotemotemotemotemotemotemot